Publicidade

terça-feira, 4 de outubro de 2016

O Sistema Operacional NixOS 16.09 "Solha" Adiciona PXE Netboot Suporte, systemd 231 .


O sistema operacional ainda usa a longo prazo apoiado Linux 4.4 do kernel


Apelidado Solha NixOS 16.09 é alimentado pelo longo prazo suportado Linux 4.4 séries kernel, utiliza o mais recente sistema systemd 231 inicialização, GCC (GNU Compiler Collection) 5.4.0 compilador e Glibc (GNU C Library) 2.24. Além disso, a pilha de gráficos foi atualizado e é baseado em X.Org Servidor 1,18.

No entanto, os usuários de AMD Radeon placas gráficas estão sendo informados de que se eles usam o driver de vídeo ati_unfree, o servidor de exibição X.Org Servidor 1,17 será usado automaticamente devido a uma incompatibilidade ABI, que afeta todas as distribuições GNU / Linux. Suporte para PXE netboot foi habilitado bem nesta versão.

"Muitos NixOS configurações e pacotes de Nix agora usar significativamente menos espaço em disco, graças ao extenso trabalho sobre redução de tamanho de encerramento. Por exemplo, o tamanho de fecho de um recipiente NixOS mínima caiu de ~ 424 MiB de 16,03 para ~ 212 MiB em 16.09, enquanto o tamanho encerramento do Firefox foi de ~ 651 MiB para ~ 259 MiB ", diz o anúncio .

melhorias de segurança, novas serivces
Para melhorar a segurança geral do sistema operacional NixOS, versão 16.09 agora vem com pacotes binários construídos usando vários recursos de proteção que foram descritos pelos desenvolvedores em um artigo detalhado na página GitHub do projeto. Além disso, um total de 56 novos serviços foram implementados.

Há muitas outras melhorias adicionados na NixOS 16.09, e entre os mais interessantes, podemos citar a substituição do gummiboot UEFI gerenciador de boot com systemd-boot, grsecurity renovada / suporte pax, devidamente digitado e verificado configuração para recipientes, e inclusão do GnuPG 2.1.x OpenPGP sistema de criptografia compatível.

O NixOS 16.09 "Solha" já está disponível para download como uma imagem ISO de 64 bits que apresenta um ambiente gráfico, bem como a 32-bit de inicialização mínimo médio instalável para aqueles que querem construir um servidor. Se você estiver atualizando de uma versão anterior NixOS, esteja ciente de tais mudanças incompatíveis .

Fonte

Até a próxima!!!